
WaveLab 7.1, WaveLab Elements 7.1, WaveLab LE 7.1 – features and improvements

Feature / Improvement Version Area

New Range indicator in the Audio Editor 

The range of the main waveform view is now displayed in the time ruler of the 
overview. It is possible to click and drag in order to change this range: click on the 
frame edge or in the middle to resize or move the range, which results in a 
comfortable scrolling or zooming procedure. If you press Control while clicking in the 
time ruler range indicator, this function is disabled and you are able to access the 
other functions such as zoom, drag and marker editing. In the Audio File 
preferences, there is also an option to have the range indicator cover the waveform 
view (Off by default). If the option is activated, the range remains editable only via 
the time ruler. 

All Versions
Audio 
Editing

Middle button click in wave area (Audio File workspace) 

As in a Montage view, clicking on the mouse "middle" button allows you to scroll the 
waveform (as done when dragging the upper part of the ruler).

All Versions
Audio 
Editing

Hint for "Operation done" 

When an audio file is edited, rendered or saved, a text hint is displayed during a few 
seconds in the status bar, e.g. "Normalize was performed in 10 s".

All Versions
Audio 
Editing

Document tab names colors 

• Audio File Workspace: when a file (such as mp3) is opened, its associated 
tab will display its name in blue, to hint that WaveLab is using a decoded 
version of the file. 

• All workspaces: the names of files that are "untitled" and are not yet already 
saved are displayed in purple colour. 

All Versions
Audio 
Editing

Enhanced Time Stretch dialog 

Enhanced Time Stretch dialog.

WaveLab 7 & 
WaveLab 

Elements 7
only

Audio 
Editing

DIRAC 3 

New DIRAC Time stretch version. Benefits: 

• time stretch up to 400% with a new mode called "Transcribe mode", which 
uses an algorithm to time stretch and pitch shift music without losing 
information critical to transcription, such as attack transients. 

• Improved processing speed, up to more than 200% (varies with stretch 
modes and Windows/Mac). 

WaveLab 7
only

Audio 
Editing

New Audio Montage: missing file handler 

Completely new approach when opening an Audio Montage with missing Audio 
Files. A specific dialog with file remapping features is now included. 

All Versions
Audio 

Montage



Feature / Improvement Version Area

Audio Montage / Clip length display 

If no audio range is selected, the Time Field in the status bar displays the length of 
the focused clip (if any). Else, the length of the Audio Montage (as in previous 
version). 

All Versions
Audio 

Montage

Plug-in resource management 

When rendering a montage, the current active plug-ins in the montage are switched 
off (and playback is stopped) to release resources before allocating plug-ins for the 
rendering process. Certain hardware-based plug-ins benefit from this procedure, as 
they can't allocate too many plug-in instances. This only happens if the option 
"Reset plug-in before rendering" is active, which is the default and recommended 
option. The plug-ins will be reactivated when playback is restarted. 

All Versions
Audio 

Montage

Convert Audio File to Audio Montage, new option 

An option "split at Generic region markers" has been added. 

All Versions
Audio 

Montage

Region creation dialog 

To improve productivity when creating marked regions, a function "Create/Name 
region from selection" has been added. There is a shortcut "Ctrl/Cmd + R" for it. 
From the dialog, you can edit the region name and type. The type is persistent from 
call to call. For WaveLab, this function is also available in the Audio Montage, which 
can be useful to create CD tracks quickly. 

Note: this shortcut was used for something else in previous version; we have 
preferred to reassign it to this function for coherence (with the "R" shortcut) and 
because it should often be called. 

All Versions
Audio 

Montage

History menu has been added to file name edit fields All Versions
Audio 

Montage

Dragging a marked region from the file browser to the Montage 

When Dragging a marked region from the file browser to the Montage, the name of 
the region is now used for the clip.

All Versions
Audio 

Montage

More detailed Track Level adjustment 

A more detailed level adjustment for track level is possible using the mouse while 
pressing the Alternate key (above a track slider). 

All Versions
Audio 

Montage

File browser displays also an audio region panel 

The file browser now displays also an audio region panel, if possible with regards to 
the context (audio file + montage).

WaveLab 
Elements 7 & 
WaveLab LE 

7 only

Audio 
Montage

Convert Audio File to Audio Montage 

When this function is activated a new dialog allows you to customize the creation of 
the Audio Montage. This feature is inherited from WaveLab 7. 

WaveLab 
Elements 7 & 
WaveLab LE

7 only

Audio 
Montage

Three Audio Montage tracks in WaveLab Elements 7

It is now possible to create up to three audio tracks. 

WaveLab 
Elements 7

only

Audio 
Montage



Feature / Improvement Version Area

Ducker plug-in in WaveLab Elements 7

The Ducker plug-in is now available in WaveLab Elements 7, which allows 
modulating the level of a clip according to the level of the track below. 

WaveLab 
Elements 7

only

Audio 
Montage

DDP Import 

Enhanced compatibility to import DDP file sets (DDP files coming from other 
software).

WaveLab 7
only

Audio 
Montage

CD report enhancements 

The header can be customized. The generated file name can be specified. 

WaveLab 7
only

Audio 
Montage

Erase selected time range 

This function has been added in the Edit menu of the Audio Montage workspace. 
The same function was available in WaveLab 6. The key shortcut had to be 
changed. 

WaveLab 7
only

Audio 
Montage

MD5 generation for DDP files 

In the global preferences, it is now possible to activate the option "Write checksum 
file (MD5)". This will cause WaveLab to write a MD5 file next to the DDP files. This 
kind of checksum is stronger than CRC-32 (hence it is often preferred). 

WaveLab 7
only

CD 
burning

Recent file lists enhancement 

After a file is saved it will appear in the list of recent files, unless it is still open in 
WaveLab. Such files will have a small "save icon overlay" to identify them in menus. 
For instance, if you save a file in mp3 format, the mp3 file will appear in the recent 
file list, with an alternative icon. Once opened and closed, the "save icon overlay" 
will not be associated to the file anymore. This feature allows easily identifying and 
opening of files that were recently exported from WaveLab. Files saved in a batch 
are not concerned.

All Versions
CD 

grabbing

Template enhancements 

1. Audio File Workspace now has templates. Creating an empty file from a 
template means creating a file with some given audio properties (sample 
rate, bit resolution, channels), but also to optionally associate it with an 
output audio file format. When the "Save as" or "Render" dialog is open, the 
associated audio file format will always be proposed as default. Note: when a 
file is saved and later reopened these template settings are no longer active.

2. Audio Montage: it is now optionally possible to include markers, clips, track 
effects. It is also possible to associate an output audio file format. When the 
"Render" dialog is open, the associated audio file format will always be 
shown as default.

From the dialog "Create document from Template" it is now possible to define a 
default template. The command "New" will directly create a document, which is
based on the template. In that case, to give access to the template list, a new 
command has been added to each workspace: "File > "New from...“. This allows you 
to create a document from any template. 

WaveLab 7 & 
WaveLab 

Elements 7

General 
Feature



Feature / Improvement Version Area

Custom Text Variables 

From the Options menu it is possible to edit text variables. Text variables can be 
used in Meta-data text fields, as well as in the CD-Report header. Their value is 
replaced before rendering the files.

For instance, you could have a variable called “%Engineer%” which will be replaced 
when rendering with e.g. a name such as "John Smith".

Additionally, there is a "Text Snippet" editable list. The text snippets that you create 
in this list can be accessed from certain text fields, such as File Names and 
Meta-Data fields. This is just a facility to avoid typing recurrent text in your workflow. 

WaveLab 7
only

General 
Feature

Master Section panel's folding state 

The Master Section panel's folding state is now stored/restored in layouts. 

All Versions
Master 
Section

More visible Master Section Bypass icon 

The important icon that symbolizes "Bypass Master Section for the active document" 
has been made more accessable. 

All Versions
Master 
Section

New "Bypass Original" switch 

This option is only available from the Master Section plug-ins for VST plug-ins and 
from the plug-in command bar. When you open a plug-in you can see a new popup 
menu that enables two choices: 

• Bypass Effect: the standard bypass, to play the unprocessed signal 

• Bypass original: this causes the difference (process signal minus original 
signal) to be played 

This new mode is especially useful for plug-ins such as Declickers, as it allows 
monitoring only the removed clicks. This is also useful to monitor what an EQ really 
does to the sound. 

Please note that certain (rare) plug-ins cause a phase shift in the processed signal. 
In that case, subtracting the original signal will not cancel it (or only partially). 

WaveLab 7
only

Master 
Section

Spectroscope range can be changed 

The display range can be set to three predefined settings. This is independent for 
the Floating meter and the Record meter. 

WaveLab 7 & 
WaveLab 

Elements 7
Meters



Feature / Improvement Version Area

Enhanced Plug-in windows 

• Plug-in windows now have a different title bar color according to their origin: 
• Master Section Pre-Master (Blue) 
• Master Section Post-Master (Purple) 
• Montage Clip (Red) 
• Montage Track (Green) 

This hint can be useful in case several plug-ins are opened at the same time. The 
colors have been symbolically chosen to map to the audio signal direction as the 
light spectrum (red to purple...) 

• The Plug-in menu is now accessable from the Title bar. This allows replacing
the plug-in without accessing the Master Section or Plug-in Tool window. 

• A fold-in/out button on the title bar has been added (double-clicking on the 
title bar does the same). If pressing Control while clicking on the Close 
button, the plug-in is removed from its slot (else the window is just hidden, as 
before).

• Plug-ins, which are opened from within the Batch processor (blocking dialog), 
keep their standard title bar and behavior. 

For consistency, a few colors have been updated in the user interface to match the 
plug-in title bar colors. This plug-in enhancement can be switched on/off in the Main 
Preferences Display tab. 

All Versions Plug-in

Improved generic plug-in windows 

Some parameters with discrete values are now visible in a check box or a combo 
box, such as the Crystal Resampler. Moreover, Control + Click reset a slider to its 
default value (but for VST-2 plug-ins). 

All Versions Plug-in

New "Stereo Tools" VST-3 plug-in. 

New "Stereo Tools" VST-3 plug-in. This tool allows Left-Right to Mid/Side 
conversion, and the inverse. Channels can be swapped, and the phase can be 
inverted for each channel. Processing happens in the same order as the parameter 
presentation (phase, swap, convert, gain). 2 simplified version of the plug-in are 
provided: 

• LR to M/S
• M/S to LR

Both plug-ins don’t have a user interface and parameters. They only do the task 
indicated by their name. 

WaveLab 7 Plug-in

Same naming behaviour now for "render" as for "save as" 

When selecting a file from the Render dialog, the standard file selector box is now in 
"Save mode", which allows inputting any name from that box. 

All Versions
Rendering 
& Import

Render specific region 

The Render dialog (Audio file and montage) has an additional option: "Render 
specific region". 

All Versions
Rendering 
& Import



Feature / Improvement Version Area

Enhanced Meta-Data management 

In the Audio File Format Dialog, concerning Meta-Data (eg. MP3 ID3 tags or BWF 
info) it is now possible to set: 

• "Don't save anything" 
• "Inherit from source file" 
• "Specific to this configuration" (and edit the Meta-Data) 

All Versions
Rendering 
& Import

Set as region name 

In the Render dialogs, the menu entry "Set as region name" has been added to the 
new menu. 

All Versions
Rendering 
& Import

FLAC Lossless Audio Codec support (read and write, and metadata) 

Note: under Windows, FLAC does not support unicode file names. 

WaveLab 7 & 
WaveLab 

Elements 7
only

Rendering 
& Import

Hint when saving an audio file in the background 

When an Audio File is being saved in the background a progress bar is now 
displayed at the bottom of the window, as when rendering. 

WaveLab 7
only

Rendering 
& Import

Drag and drop or Copy and Paste from MediaBay/Cubase/Nuendo to WaveLab 

From the MediaBay, only audio files available on your media can be copied (ie. not 
VST sounds). Events can be dragged and drop into WaveLab or Copy/Paste can be 
used (in this last method an active Cubase forces the waveform to be copied tills its 
end; this is why Drag/drop is recommended). It is also possible to drag files from 
WaveLab into Cubase/Nuendo (drag the file tab). Audio Ranges cannot be exported 
that way so far. 

All Versions
Steinberg 
integration

Window splitters 

• Slightly easier identification of window splitters (eg. move the mouse over a 
splitter). 

• Double clicking on a splitter, collapse or uncollapse the panels (not for 
splitters between Tool Windows). 

All Versions
User 

Interface



Feature / Improvement Version Area

Tool Windows enhancements 

1. Specific and Shared Tool windows now have a small visual distinction. 
• Specific tool windows have a title bar with a lighter color and their 

title is in black. Moreover, when they float, the same title bar is kept
to recall their connection to the workspace. Moreover they have a 
Dock/Float priority button. 

• Shared tool windows have a title bar with a darker color and their 
title is in black. When they float, they have a standard operating 
system title bar, in order to recall they are independent from any 
workspace. 

2. There is now a title bar folding button for docked tool windows, located just 
before the bar title. A folded bar gives slightly more space for the more 
useful contents area. A very thin bar remains visible. 

• There is also the option to fold/unfold the title bar automatically (off 
by default). The option can be toggled in Options > Global 
preferences > Display. When this option is activated, simply move
the mouse cursor over the thin bar. When this option is activated, 
the "manual" fold button is not visible. By design, empty shared tool 
windows are not concerned by the Auto fold feature. 

3. Dock/Float priority button: if you want to move a floating Tool window 
anywhere, without docking it, this button need to be checked. The same 
behavior can be achieved by pressing Control before dragging the window. 

• When a specific Tool Window floats and is resized, this size will be 
remembered with the Workspace layout. This means next time you 
make it float, you will find it at the same place. One interest of this: 
you could have a small docked window, and a large floating 
window. When you need to do more work on the window, make it 
float temporarily, to be more comfortable. 

• The icon associated to each Tool window, is now visible in the 
menus that toggle the Tool Window visibility. 

• A shortcut can now be assigned to toggle the visibility of each Tool 
window (specific and shared). Moreover, a command bar can now 
be setup to display a switch to each Specific Tool Window. These 
options are set from menu Options > Customize commands > 
Workspace menu. This allows some new kind of workflow, 
especially for small screens: all specific tool windows can be closed 
by default, to save space. And with a shortcut or a single button 
click, the desired specific tool window can popup. 

4. Each docked shared tool window, if empty, now has a specif large button to 
recall the contents, rather than a small blue button at the top right. 

All Versions
User 

Interface

Enhanced "Customize commands" dialog 

Enhanced "Customize commands" dialog. An intuitive search function allows to 
quickly locate the desired commands. Please note: the filtered results correspond to
the target of all "Reset" and "Print" commands. 

Menus and Sub-menus are now displayed in bold, for better visibility. 

All Versions
User 

Interface



Feature / Improvement Version Area

Switcher enhancements 

Each Switcher button now displays a small "LED" to give a hint about its associated 
window status. It's a simple but useful concept in practise: 

• No hint: there is no instance of the workspace. 

• Light green: the related workspace is fully active (all shortcuts are enabled) 

• Dark green: the related workspace exists, but is not the front active 
workspace. 

• Orange: the related workspace is the front workspace, but it is not the active 
window. Another non-blocking window is the active window. The workspace 
can be made active anytime. Most shortcuts won't be enabled, because the 
workspace is not active (on the Mac, more shortcuts are enabled in 
comparison to Windows, because of operating system differences). Clicking 
the button once makes the workspace active again. 

• Light Red: the related workspace is the front workspace, but it is not the
active window. Another blocking window is the active window or a blocking 
process is going on. The workspace will be made active again when the 
blocking window closes. The Switcher button is also greyed because clicking 
on it has no effect (but on the Mac, where clicking activates the application, if 
another application is active). 

• Dark-Red: the related workspace is not the front workspace. Another 
blocking window is active. The workspace can be made active again only 
when the blocking window closes. 

• Light Purple: the related workspace is the front workspace, but WaveLab is 
not the activate application. If WaveLab is activated, this workspace will be 
the active one, by default. 

• Dark Purple: the related workspace is existing, but is not the front workspace, 
and WaveLab is not the activate application. 

When a blocking window is opened, the Switcher button is also greyed out. Clicking 
on it has no effect (but on the Mac, where this activates WaveLab if another 
application is active at that time). 

The Control Window button's behavior has slightly changed: if the Control Window is 
the active window, clicking on that button causes the window to close (as far as 
there is a remaining workspace). 

Shortcuts: If you click on a switcher button with “Shift” a new document is opened of 
the corresponding type (file selector box opens). “Control”: a new document of the 
corresponding type is created. “Control + Shift”: this opens the template dialog, to 
create a new document from a template (WaveLab 7 only). 

All Versions
User 

Interface

Mac: more popup menus displaying icons. 

Mac: more popup menus displaying icons. 

All Versions
User 

Interface

Workspace document tabs

Document activation improvement: 

• When opening a new file, its Tab will now be created right after the active 
Tab and not systematically as last Tab. 

• When closing an active Tab, it is now activated on its right side. This is the 
default option, but can be changed according to a new preference in Options 
> Global preferences > Display. 

• In case multiple files are opened at the same time, the first one (left most 
side) is activated.

All Versions
User 

Interface



Feature / Improvement Version Area

Tab busy indicator 

When an Audio File or Montage is rendered an animation is shown in its tab. 

All Versions
User 

Interface

Time indicators 

All progress dialogs that show a progress bar now also display "Elapsed" and 
"Remaining" times. This is also the case for non-blocking progress bars at the 
bottom left of audio windows, e.g. during the rendering process. 

All Versions
User 

Interface

Copy file name function in tab context menu 

When right-clicking on a tab, a new menu allows copying the file name or parts of it 
into the Clipboard. The same menu is present in Workspace menus: File > Special. 

All Versions
User 

Interface

Easier identification of most tool windows 

Tools windows that are empty ("uniform while background") as well as lists and 
tables now display a large faded icon for better identification. 

All Versions
User 

Interface

Easier identification of Status Bar text fields 

Easier identification of Status Bar text fields (Audio Files and Audio Montages).

All Versions
User 

Interface

"Save as" dialog enhancements 

• The "File Save As" dialogs now have the option "Automatically open system 
file selector". 

• When typing a file name, all existing files that start with the same letters
within the active folder are displayed in a popup window. 

• A new button shows all files in the active folder. 
• For the "Save Audio File" dialog, certain feedback messages can appear, 

according to the active settings. 

All Versions
User 

Interface

New Switcher bar inside workspace 

New Switcher bar inside workspace. This bar is optional but present by default. It
works comparable to the floating switcher bar, but it does not hide anything. By 
default, the floating switcher bar is now only visible if WaveLab is not the active 
application (eg. to facilitate drag and drop). This behaviour can be changed within 
the global preferences. Size, position and visibility of the bar are saved with each 
workspace layout. The contents (buttons inside) are common to all workspace 
layouts (for a given workspace type). 

All Versions
User 

Interface

Option: "Display file extension in tabs" 

If this option is activated, tabs will display file names with their extension. For 
instance, "Piano.mp3" will be displayed rather than "Piano". This takes a bit more 
space, but can be useful as the Audio File Workspace can edit files from various 
formats. This option is OFF by default and can be activated in the preferences of the 
Audio File workspace. 

All Versions
User 

Interface

Option: "Display active file path in title bar" 

This option is activated by default and can be toggled in the Global preferences > 
Display tab. 

All Versions
User 

Interface



Feature / Improvement Version Area

Save all dialog 

A column "Type" has been added to better identify the files to save. 

All Versions
User 

Interface

Double clicking on a marker head 

• Set the cursor to this position: Starts playback from this position, if 
“Control/Command” is pressed.

• Activate the Marker Tool Window if Alternate is pressed.

All Versions
User 

Interface

Control window / Hide Frame Status 

The Control Window now remembers the "hide frame" setting when saving/restoring 
a layout. 

WaveLab 7
only

User 
Interface

Enhanced preset display in command bars 

When a preset is set to be included in a Command bar (from the "Customize 
commands" dialog):

• If the preset is included in a sub-menu of the media, this folder will be 
displayed on the command bar (to group several presets under a single 
command bar button). 

• If the preset is included in a sub-menu (eg. Workspace Layout), and this 
sub-menu is set to be included in a command bar, then a single button will 
represent this sub-menu on the command bar (the interest is have a faster 
access to the sub-menu items). This feature was partially implemented in the 
previous version. 

• When a button, in a Command bar, represents a custom preset, its popup tip 
now displays the preset name in bold. 

WaveLab 7
only

User 
Interface

External tools in command bar 

A custom external tool can now be included in a command bar. 

WaveLab 7
only

User 
Interface

Background Task Window 

Background task window: A column "Elapsed time" has been added. 

WaveLab 7
only

User 
Interface

Play a sound when a long task completes 

This is a new, customizable option in the main preferences. The file format needs to 
be .wav or .aiff. 

WaveLab 7
only

User 
Interface
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